Posteado por: Jesus | 25 marzo, 2010

Error SAMBA 3.0.28a-1ubuntu4.11 + Enlaces simbólicos

Esta mañana he recibido en mi Ubuntu 8.04 unas actualizaciones de los paquetes que componen SAMBA , actualizándose la versión  3.0.28a-1ubuntu4.10 a la nueva  3.0.28a-1ubuntu4.11.

Todo parecía correcto pero al intentar entrar desde Windows a alguna carpeta compartida en mi servidor Linux, han aparecido errores, ya que no era posible acceder a las carpetas, que eran en realidad ‘enlaces‘ a otras carpetas.

Después de comprobar que los permisos de la carpeta eran los correctos, reiniciar el servicio de SAMBA y que no había ningún otro problema a primera vista, he mirado el log del sistema (/var/log/syslog.log). Aquí se podía ver claramente el error que se estaba produciendo

Share ” has wide links and unix extensions enabled. These parameters are incompatible. Wide links will be disabled for this share.

Al parecer ha habido un cambio en Samba, como explican aqui:

http://marc.info/?l=samba-technical&m=126548356728379&w=2

La solución como comentan en el punto 1, es añadir estos parámetros en nuestro archivo de configuración del SAMBA (/etc/samba/smb.conf)

unix extensions = no
wide links = yes

Reiniciamos el servicio SAMBA y todo vuelve a funcionar sin problemas.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Categorías

A %d blogueros les gusta esto: