Posteado por: Jesus | 6 abril, 2008

Firestarter en Ubuntu 8.04

Hola, aqui continuamos con Ubuntu 8.04.

Un pequeño problema que he tenido ha sido instalar firestarter (un cortafuegos para Gnome). Ya se que ubuntu presenta como novedad ufw, un firewall que estará a disposición del usuario aunque vendrá “apagado” por defecto, pero controlado desde la consola.

Despues de instalar firestarter (sudo aptitude install firestarter), me daba un error y no lograba arrancar el cortafuegos. Despues de buscar un poco encontre la solucion.

Editatmos este archivo:
gksu gedit /etc/firestarter/firestarter.sh

Y buscamos esta linea:
MASK=`/sbin/ifconfig $IF | grep Mas | cut -d : -f 4`

que busca a la salida de ifconfig las líneas con palabras que contengan Mas (por Mascara) pero en Ubuntu la salida de ifconfig produce la palabra Máscara con acento en la a. Simplemente cambiando la línea anterior por

MASK=`/sbin/ifconfig $IF | grep Más | cut -d : -f 4`

Ya nos funciona Firestarter. 😉
Otro pequeño problema que tiene Ubuntu es configurar Firestarter, para que se muestre en la barra de aplicaciones de nuestro escritorio.

Este problema se produce al ejecutar ‘sudo firestarter’ al inicio de sesión. Tenemos que modificar el archivo de configuración de sudo, para que podamos ejecutar este comando sin contraseña y sin problemas.

Mi archivo ‘/etc/sudoers’ queda de esta manera:

Hay que modificar del archivo original, la linea de ‘Defaults’ y añadir la ultima linea para que nuestro usuario pueda ejecutar sin contraseña el comando del cortafuegos.

Defaults !lecture,tty_tickets,!fqdn,env_keep+=”DISPLAY HOME XAUTHORIZATION”

jesus  ALL= NOPASSWD: /usr/sbin/firestarter


(OJO, no copiar y pegar la linea Defaults en /etc/sudoers, ya que al pegar pone las dobles comillas invertidas, y da error al hacer un sudo, asegurarse que las dobles comillas son normales, y no invertidas)

Ya solo nos falta añadir en la sesión de inicio de Gnome firestarter, así que añadimos en Sistemas -> Preferencias -> Sesiones el comando sudo firestarter –start-hidden‘ para que se ejecute al inicio, minimizado en la barra de aplicaciones.

Y ya tenemos nuestro cortafuegos listo para ejecutarse sin problemas. 🙂

Anuncios

Responses

  1. […] hoy se ha actualizado Firestater, por lo que he tenido que repetir este paso para que funcionase de […]

  2. A mi m e ha deajdo el sistema sin privilegios de administrador con lo que con mi experiencia me ha tocado instalar todo de nuevo, asi que hay que tener cuidado. gracias

  3. Hola Antonio,
    Hace unos meses me paso algo parecido, me equivoque al editar ‘/etc/sudoers’ y no podia ejecutar nada como administrador.
    Tuve que entrar en mi otro linux para poderlo modificar y arreglarlo 🙂

  4. Mil!!!! gracias….no sabia comno hacerle para instalarle XD…gracias chau

  5. muchas graciass 🙂


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Categorías

A %d blogueros les gusta esto: